(時間電卓 ヘルプ インデックス)

  時間電卓（β版）　ヘルプ トピック

※１日を　７時間４５分、８時間、２４時間　として、時間の足し算、引き算をすることができます。

起動すると、次の画面が現れます。
左のエディットボックスには時間の「累計」を、右のエディットボックスには時間の「残り」を表示します。

使い方

①とりあえず、「40」と書いてあるボタンを押してください。

  「残り」を表示するエディットボックスに　40日　と示されます。

  つまり、残り時間が40日に設定されました。同様に「20」を押すと残り時間20日に設定することができます。

  その他の時間は、例えば「35日5時間15分」に設定したければ、

  マウスで「3」「5」「日」「5」「時」「1」「5」「分」とすると、左のエディットボックスに「35日5時間15分」が表示されます。

  次に「→」を押すと、右のエディットボックスに「35日5時間15分」が表示され、その時間が残り時間に設定されました。

②残り時間「40日」に設定されている状態で、「１」「日」とボタンを押すと、左のエディットボックスに「１日」が表示されます。

  さらに、「＋」ボタンを押すと左のエディットボックスには「１日0時0分」、右のエディットボックスには「39日0時0分」が表示され、累計と残りが計算されました。

  続けて、「５」「時」「＋」とすると左のエディットボックスには「１日5時0分」、右のエディットボックスには「38日2時45分」が表示されます。

  「１日5時0分」と「38日2時45分」を加えると「39日7時45分（=40日）」ですので7時間45分進法で正しく計算されていることがわかります。

ボタン等の説明 |
「１」～「0」 | 数字を入力します。
「日」「時」「分」 | 数値に時間を付加します。このボタンを押さないで、数字のままだと計算されません。
「＋」「－」 | 時間を加算、減産します。
「＝」 | 計算をします。
「Ｃ」 | クリアボタン。入力したエディットボックスの内容を破棄します。
「AC」 | オールクリアボタン。計算している全ての内容を破棄します。
「→」 | 左のエディットボックスの内容を右のエディットボックスに移動します。
「Ｆ」 | ファンクションボタン。 「累計・残りモード」と「加算・減算モード」の切り替えをします（下参照）。
「40」「20」 | 残り時間を「40日」「20日」に設定します。
「▽」 | オプションボタン。 時間設定変更ボタン「７時間45分」「８時間」「24時間」を表示させます（下参照）。

オプション

１日の時間の設定を変えることができます。

  一番、右下の「▽」ボタンを押すと、オプションボタンが現れます。

  「７時間45分」「８時間」「24時間」のボタンを押して、設定を変えてください。

  「▽」ボタンを再び押すとオプションボタンがかくれます。

引き算

時間の引き算をすることができます。

  右上の「Ｆ」ボタン（ファンクションボタン）を押すと、残り時間を表示するエディットボックス等が消えます。

  単純な時間の足し算、引き算ができます。１日の時間設定は「▽」ボタンで行ってください。

できないこと
  ①キーボードの入力はできません。マウス操作のみです。
  ②入力した数値の整合性を検知しません。たとえば「25時間65分」という入力も許可します。計算は正常に行えます。
  ③乗算、除算はできません。　７時間45分×３日　などできるといいんですが。